Lo hice y lo entendí

El blog de Vicente Navarro
18 nov

Ya tenemos un plugin de Flash nativo para Linux de 64 bits

Hoy la noticia buena y mala del día para los usuarios de Linux ha sido que Adobe ha liberado una versión alpha de su plugin Flash para navegadores: Barrapunto: Flash para 64 bits llega primero a Linux, Penguin.SWF: Now Supporting 16 Exabytes, Descargar versión de Linux de 64 bits de Flash Player 10.

Es una noticia buena para los usuarios de Linux AMD64 después de tanto tiempo pidiéndolo, porque el plugin de Flash es vital para nuestros sistemas de escritorio si queremos tener una experiencia completa en el uso de la web hoy en día. Su alternativa abierta, el Gnash, aún no está preparado para reemplazarlo completamente. La única opción que teníamos era usar el plugin de 32 bits con el nspluginwrapper (Sobre el plugin de Flash en Firefox/Iceweasel en Debian AMD64: El nspluginwrapper aceptado en Testing), una opción que, aunque nos saca del apuro, es muy inestable y nos obligaba muy a menudo a reiniciar el navegador porque el plugin de Flash dejaba de funcionar.

Es una noticia muy mala para los usuarios de Linux porque es lamentable que en nuestro sistema, que nos gustaría ver libre de todo el software propietario, tengamos que pasar por el aro de dos cosas: del dichoso plugin de Flash y de los drivers cerrados. No es casualidad que a menudo sean componentes de software de nuestros sistemas que desearíamos que fueran algo más estables. Es muy desafortunado que tengamos que depender de que los señores de Adobe sean magnánimos con los pobres bichos raros que usan Linux de 64 bits para poder usar lo que todo el mundo usa, Internet.

Y por supuesto, también es lamentable que diseños web que se podrían hacer de forma perfectamente estándar y llamativa con un poco de CSS, HTML y JavaScript, acaben siendo pasto del todopoderoso y monopolístico Flash para desesperación de aquello que llamamos accesibilidad. El uso de Flash para reproducir vídeos en la web es razonable, aunque sería mucho más deseable que se usara cualquiera de los formatos de vídeo abiertos disponibles. Donde sí tiene perfecta cabida, hay que reconocerlo, es en el campo de las animaciones, como los juegos online o los típicos esquemas interactivos que a menudo nos presentan los periódicos en su edición digital.

Bueno, yo he probado hoy esta nueva versión del plugin en mi Ubuntu 8.10 y he de decir que funciona. No lo he probado intensivamente, pero funciona bien con algún juego (¿habéis probado el Play 99 Bricks?) y con Youtube, Metacafe y ZappInternet. Sin embargo, me da la sensación de que usa muchísima CPU.

Para instalarlo, he desinstalado el paquete flashplugin-nonfree:

 $ sudo dpkg -P flashplugin-nonfree
(Reading database ... 134935 files and directories currently installed.)
Removing flashplugin-nonfree ...
Purging configuration files for flashplugin-nonfree ...

y he hecho un autoremove para que elimine el nspluginwrapper también:

$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  nspluginwrapper
The following packages will be REMOVED:
  nspluginwrapper
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 483kB disk space will be freed.
Do you want to continue [Y/n]? 
(Reading database ... 134928 files and directories currently installed.)
Removing nspluginwrapper ...
Processing triggers for man-db ...

Finalmente, he descargado el fichero libflashplayer-10.0.d20.7.linux-x86_64.so.tar.gz libflashplayer-10.0.d21.1.linux-x86_64.so.tar.gz y lo he descomprimido en el directorio ~/.mozilla/plugins. Sólo contiene una librería:

~ $ wget http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.d21.1.linux-x86_64.so.tar.gz

~ $ cd .mozilla/plugins/

~/.mozilla/plugins $ tar xvf ~/libflashplayer-10.0.d20.7.linux-x86_64.so.tar.gz
libflashplayer.so

Tras reiniciar el navegador, en el about:plugins ya veremos:

Shockwave Flash

File name: libflashplayer.so
Shockwave Flash 10.0 d20

Para instalar el plugin para todos los usuarios del sistema, habría que copiar la nueva librería en /usr/lib/mozilla/plugins/.

En fin, que la noticia deja un sabor muy agridulce. Es como cuando el driver de NVidia va mal y la actualización del driver cerrado arregla el problema. Se agradece la actualización, pero ésta no mitiga la impotencia que da depender de la voluntad que tenga una empresa para arreglar fallos o no hacerlo.

Actualización 20/11/08: The Inquirer: Instalación y rendimiento Adobe Flash 64bits en Linux

:wq

Entradas relacionadas

14 Comentarios a “Ya tenemos un plugin de Flash nativo para Linux de 64 bits”

  • el_salmon dice:

    Hombre, es una pena, es cierto, pero el dominio de la tecnologia Flash ya es inevitable asi que lo unico que podemos hacer desde la comunidad del software libre es apoyar las alternativas opensource como Swfdec (del que hice un ebuild para Gentoo cuando usaba un Mac Mini PowerPC) y Gnash (más inestable que Swfdec en mi humilde opinion).

  • trinux dice:

    ¿Pasar por el aro? Oiga usted, use gNewSense.

    Tengo compilado gnash 0.8.4, el último disponible a fecha de hoy, y lo tengo más por tenerlo, y ver como avanza, que otro cosa. Te saca de algún apuro, pero para cosas recientes hechas en flash, por decirlo de alguna forma, es más una molestia que nada; carga mucho el sistema.

  • @el_salmon, @trinux Pues sí, así es, la solución pasa por que Swfdec o Gnash mejoren hasta casi el nivel del Flash, pero parece tan lejos el día en que eso ocurra…

    Y sí, trinux, tienes mucha razón, no tenemos obligación de “pasar por el aro” en esto, pero ya ves que aún me queda algo de pragmatismo y prefiero hacerlo ;-)

  • Sagman dice:

    Pues si, es una pena muy grande que tengamos que pasar por el aro para hacer funcionar correctamente segun que cosas, pero es lo que hay. Aunque siempre debemos apoyar las alternativas libres ya que tienen un gran futuro.

    Saludos

  • nacho dice:

    Pues sí, funciona perfectamente con Firefox. Pero konqueror (4.1.3), aunque reconoce perfectamente el plugin, no funciona youtube. Otros contenidos flash sí van.

    Saludos

  • nadie dice:

    ¿Que Adobe ha liberado el plugin flash para 64bits?
    ¡Eso es la leche!

    ¿Dónde puedo descargar el código fuente?

  • Manuel dice:

    Pues en parte me has alegrado el día… porque estos problemas con Flash es algo que aprendí cuando me instalé Kubuntu 8.10 en el portátil hace unas semanas…

    Y tuve que recurrir al Iceweasel y demás historias para el tema del flash, y lo cierto es que casi nunca funciona bien.

    Lo de Youtube es normal, no te preocupes… el Flash que tienen para los vídeos es una castaña, y consume muchos recursos. Yo en el sobremesa no lo noto, pero en el portátil de casa que lleva un Celeron M sí. Veo un vídeo en DailyMotion, o alguno de algún juego en VidaExtra.com y los veo sin problemas… pero en YouTube siempre se atascan tirando muchísimo de CPU.

    A mi Flash tampoco me hace mucha gracia, pero como no tenía alternativa (similar) se ha ido imponiendo en todas partes. Pero es cierto que con CSS y JavaScript se pueden hacer muchas cosas bien chulas…
    De hecho para un amigo le monté una Web para su Agencia de Publicidad, y en lugar de Flash (más que nada porque no se, y tampoco me parece nada sencillo) los efectos que me pedía se lo monté con Javascript… y es curioso ver lo mucho que se puede hacer con Javascript y CSS… :D

  • @Manuel Pues así es, el Flash es un mal necesario, así que mejor tenerlo también en 64 bits que no tenerlo. Y sí, el uso de CPU de estos vídeos es abrumador, y eso que los de Adobe dicen que ahora el Flash usa aceleración hardware…

  • ary miguel dice:

    Yo traté de instalarlo, pero no pude, porque al momento de querer copiarlo a la carpeta plugins de firefox no me da permismos de copiarlo y que solo root lo puede dar privilegios para leer y escribir en esa carpeta :( utilizo ubuntu 8.10

  • @ary miguel Si lo copias al directorio .mozilla/plugins/ de tu usuario como sugiere la entrada, necesariamente te ha de dejar.

  • Salud a tod@s:
    Estoy hasta la mismísima de que se me cierren páginas cada dos por tres, cosa que no me pasaba con el “nonfree” y, total, para cuatro vídeos chorras que veía en youtube…
    ¿Cómo diantres puedo desinstalar éste y volver al “nonfree”? He probado a borrar el .so de marras pero sigue igual.
    Sí, ya lo sé, soy un paquetillo… pero tenía que preguntarlo.
    ;-)

  • No, no soy un paquetillo… soy un “PAQUETE” (perdón por levantar la voz). Bastaba con desactivarlo desde Herramientas>Complementos en Firefox.
    Gracias a tod@s por estar ahí.

Trackbacks y pingbacks:

Tema LHYLE09, creado por Vicente Navarro