Lo hice y lo entendí

El blog de Vicente Navarro
02 ago

Sobre el plugin de Flash en Firefox/Iceweasel en Debian AMD64: El nspluginwrapper aceptado en Testing

Me encanta tener el Debian AMD64. Lo uso desde que tengo mi ordenador principal con un procesador Athlon64 y cuando el AMD64 aún no era una arquitectura oficialmente soportada por Debian (lo es desde Debian 4.0 Etch). Eligiendo este port liberamos a nuestro ordenador de compatibilidades hacia atrás con arquitecturas de hace 20 años (386) y elegimos binarios que únicamente se tienen que ajustar a modelos mucho más recientes de procesadores (el primer Opteron con soporte de AMD64 salió en el 2003).

La única pega por la que me he sentido siempre atado ha sido el plugin de Flash Player, ya que aunque existe para Linux, Adobe aún no se ha dignado a sacarlo para plataformas de 64 bits. Ni siquiera tras la salida del Flash 9:

When will a 64-bit version of Adobe Flash Player for Linux be available?

The Adobe Flash Player team is working on support for 64-bit platforms as part of our ongoing commitment to the cross-platform compatibility of Adobe Flash Player. We have not yet announced timing or release dates.

Que no se me entienda mal… yo odio el abuso de los contenidos en Flash, como todo hijo de vecino que entiende cómo funciona una web y la indexación de contenidos por los buscadores y la accesibilidad y todo eso. Sin embargo, entiendo que el producto tiene su nicho de mercado legítimo en los contenidos multimedia, como juegos, animaciones, aplicaciones interactivas y… ¿cómo no? En vídeos. Mientras que tradicionalmente ha sido un lío configurar un Linux para poder ver bien los vídeos incrustados en páginas web, el Flash Player ha llegado y nos ha resuelto todos los problemas de un tacazo. ¿Qué internauta linuxero de hoy en día tiene problemas para ver vídeos de YouTube o similares con el plugin de Flash Player?

En mis primeros días de usuario de Debian AMD64, la solución era tener un Debian i386 chrooteado en el sistema: Using an IA32 chroot to run 32bit applications. No era la solución más cómoda del mundo pero bueno, funcionaba… Hacías tu:

chroot /linux32
export DISPLAY=localhost:0.0
firefox &

tras los xhost de turno en el servidor X y a funcionar…

Luego pasé a desinstalar el Firefox oficial de 64bits de Debian y a instalar el de 32bits (i686) de la web de Mozilla. Y finalmente acabé con el Swiftfox (swift=rápido), una versión de Firefox con opciones de compilación específicas para distintos procesadores. Ambos navegadores necesitan las librerías de 32 bits de Debian AMD64:

ia32-libs
lib32gcc1
libc6-i386
lib32z1
lib32stdc++6
lib32asound2
lib32ncurses5
ia32-libs-gtk

La lástima es que me daban problemas porque en los diálogos, como el “Guardar como…/Save as…” me salían cuadraditos en el lugar de las letras, como si no pudiera cargar bien la fuente correspondiente. Esto le pasaba a mucha gente más, como se puede ver en los comentarios de Howto Install 32 bit Firefox with Flash w/sound and Java for AMD64 (del foro de Ubuntu). Nota: Curiosamente he querido reproducir el problema para documentarlo aquí y ya no me vuelve a ocurrir. En la versión Testing/Lenny que estoy usando ya deben de haber solucionado el problema, pero en cualquier caso, los errores que me daban eran también con la libpango, como cuentan en el foro.

Y en esas estaba yo ayer cuando “apt-cache searcheando” algo, ya no sé el qué, encontré esto:

# apt-cache show flashplugin-nonfree
Package: flashplugin-nonfree
Priority: optional
Section: contrib/web
Installed-Size: 140
Maintainer: Bart Martens <bartm@knars.be>
Architecture: amd64
Version: 9.0.48.0.2
Replaces: flashplugin (<< 6)
Depends: debconf | debconf-2.0, wget, fontconfig, ia32-libs-gtk, lib32z1, nspluginwrapper (>= 0.9.91.4-3)
Suggests: iceweasel, konqueror-nsplugins, x-ttcidfont-conf, msttcorefonts, ttf-bitstream-vera | ttf-dejavu, ttf-xfree86-nonfree, xfs (>= 1:1.0.1-5)
Conflicts: flashplugin (<< 6), xfs (<< 1:1.0.1-5), flashplayer-mozilla
Filename: pool/contrib/f/flashplugin-nonfree/flashplugin-nonfree_9.0.48.0.2_amd64.deb
Size: 15326
MD5sum: 3b8be99000f939effe9e857f486278cd
SHA1: be18e275c98d953f32435bdff878d618fff20075
SHA256: 2f51acc2141eaf288bd7e917dd57ff2480d8e50e09aaac49c52b6e999f04afa0
Description: Adobe Flash Player plugin installer
 This package will download the Flash Player from Adobe.  It is a
 Netscape/Mozilla type plugin.  Any browser based on Netscape or Mozilla can
 use the Flash plugin.  This package currently supports the following browsers:
 Mozilla, Mozilla-Firefox, Firefox, Iceweasel, and Iceape.  Also Galeon and
 Epiphany can use the Flash plugin.  Konqueror can also use the Flash plugin if
 konqueror-nsplugins is installed.
 .
 WARNING: Installing this Debian package causes the Adobe flash plugin to be
 downloaded from www.adobe.com.  The distribution license of the Adobe flash
 plugin is available at www.adobe.com.  Installing this Debian package implies
 that you have accepted the terms of that license.
 .
  Homepage: http://wiki.debian.org/FlashPlayer
Tag: suite::mozilla, use::browsing

y me quedé anonadado pensando cómo podía haber ya plugin de Flash para AMD64. Rápidamente desinstalé el Swiftfox e instalé el Iceweasel y dicho paquete del Flash Player:

# apt-get install flashplugin-nonfree iceweasel libasound2-plugins mozplugger
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  ia32-libs ia32-libs-gtk lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc+
  libavutil1d libc6-i386 libmyspell3c2 linux32 nspluginwrapper
Suggested packages:
  iceweasel-gnome-support
The following NEW packages will be installed:
  flashplugin-nonfree ia32-libs ia32-libs-gtk iceweasel lib32asound2 lib3
  lib32stdc++6 lib32z1 libasound2-plugins libavcodec1d libavutil1d libc6-
  mozplugger nspluginwrapper
0 upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
Need to get 44.1MB of archives.
After unpacking 122MB of additional disk space will be used.
Do you want to continue [Y/n]?

Cuando acabó y vi que funcionaba, me puse a investigar y encontré que la clave del misterio estaba en ese nspluginwrapper, una capa entre el Firefox/Iceweasel de 64 bits que permite usar plugins de 32 bits:

# apt-cache show nspluginwrapper
Package: nspluginwrapper
Priority: extra
Section: contrib/utils
Installed-Size: 348
Maintainer: Rob Andrews <rob@choralone.org>
Architecture: amd64
Version: 0.9.91.4-3
Depends: ia32-libs (>= 1.6), lib32gcc1 (>= 1:4.2-20070516), libc6 (>= 2.5-5), libc6-i386 (>= 2.5-5), libglib2.0-0 (>= 2.12.9), libx11-6, libxt6, ia32-libs, ia32-libs-gtk, linux32
Filename: pool/contrib/n/nspluginwrapper/nspluginwrapper_0.9.91.4-3_amd64.deb
Size: 102180
MD5sum: c71e8d3e03721bad749b3143e45634fa
SHA1: 32e8dee0a769dc40b7d5a549571653bee319af70
SHA256: a751d3240cb4b71bee770b4761c117ac3c3141e9a28652b62cbf908e7b670694
Description: A wrapper to run Netscape plugins on other architectures
 nspluginwrapper is an Open Source compatibility plugin for Netscape 4
 (NPAPI) plugins. That is, it enables you to use plugins on platforms
 they were not built for.
 .
 This package is built to run i386 plugins, since there are no known
 binary-only plugins built for any other architecture.
Tag: implemented-in::c, role::plugin, role::shared-lib, suite::mozilla

Bueno, pues resulta que este paquete de Debian Testing de nspluginwrapper que ha conseguido que reconcilie ya todas mis diferencias con el Debian AMD64 existe desde hace ya casi dos años, está en Unstable desde abril del 2007 y en Testing desde hace unos 20 días…

¡Oye! ¡Y yo sin enterarme antes! Pues que lo sepa todo el mundo: Si tienes Debian AMD64 Testing/Lenny, ya puedes usar un Iceweasel nativo de 64 bits con el plugin de Flash Player usando el nspluginwrapper.

Entradas relacionadas

33 Comentarios a “Sobre el plugin de Flash en Firefox/Iceweasel en Debian AMD64: El nspluginwrapper aceptado en Testing”

  • minWi dice:

    Los usuarios de ppc y linux seguimos marginados :(

  • Iván dice:

    Enhorabuena!!. Una cosa más solucionada para los usuarios de linux, aunque sea un poco tarde; mejor tarde que nunca.

    Saludos, Iván.

  • minWi Ya lo siento :-( Para vosotros la guerra es aún más dura… y para los de Free/Net/Open BSD todavía más…

    Iván Gracias :-)

  • Andrés dice:

    Excelente información! lo acabo de configurar y funciona muy bien.

    Un dato importante:
    Si es que antes estaba instalado, debe ser eliminado el paquete libflash-mozplugin

    #apt-get remove libflash-mozplugin

    Nuevamente muchas gracias.

  • Andrés ¡Gracias por la información! :-)

  • pepe dice:

    y pregunto:

    si mi sources dice

    deb http://ftp.fi.debian.org/debian/ etch main contrib non-free
    deb-src http://ftp.fi.debian.org/debian/ etch main contrib non-free

    ¿tengo que agregar o modificar?

    si modifico, TODO será testing (demasiado novato para ello)

    ¿puede convivir estable y testing? ¿lío de aptitudes?

    gracias

  • pepe Aunque es posible tener algún paquete suelto de testing o de unstable te aseguro por propia experiencia que mezclar ambos es asegurarte de tener un buen follón de dependencias y problemas.

    Si quieres tener todo el sistema en testing, pon:

    deb http://ftp.fi.debian.org/debian/ testing main contrib non-free
    deb-src http://ftp.fi.debian.org/debian/ testing main contrib non-free

    y a continuación “apt-get update” y “apt-get dist-upgrade“. Ten en cuenta que esta decisión no tiene fácil marcha atrás, aunque yo logré pasar una unstable a testing por el sencillo sistema de esperar a que los paquetes de testing comenzaran a reemplazar a los que yo tenía de unstable. También, en vísperas de la salida de etch pasé una testing a stable con el mismo método, pero claro, no salen stables todos los días…

  • Soy descocada... dice:

    sabes tengo un problema ya no se que hacer …. cuando pincho para ver algún video muestra este msj “this swf file is known to trigger bugs in the swfdec decoder”. no lo sé ya lo e instalado todo y no encuentro una solución…

  • Soy descocada… Creo que estás usando swfdec para reproducir animaciones Flash, un reproductor de código abierto, y no el reproductor de Flash para Linux de Macromedia, un paquete non-free que se instala tal y como comento en la entrada.

  • Soy descocada dice:

    sabes… he revisado y nada, el swfdec no esta instalado o al menos no lo he encontrado … el problema se me presenta es cuando quiero ver vídeos en el navegador… en iceweasel me aparece el mensaje anterior y en Galeon no aparece nada .. que debería desintalar para corregir…

  • Soy descocada Haz un “dpkg -l swf-player“. Si te sale como instalado es que tienes el swfdec y por eso te salen esos errores. Como te comento, necesitas instalar el paquete flashplugin-nonfree tras añadir el repositorio non-free al fichero /etc/apt/sources.list.

  • Karso dice:

    Excelente aporte, tenia dias intentando instalar el dicho plugin y no podia pero ahora ya quedo listo lo unico que tienen que hacer es agregar este repositorio para que se descargue todo bien:deb http://apt.64studio.com/64studio/testing 64studio

  • Karso ¡Me alegro de que te haya resultado útil!

  • iqpi dice:

    Hola, interesante blog, felicidades por el trabajo.

    Hace unos meses seguí los pasos que comentas arriba para la instalación del flash en lenny64, pero allá por diciembre el flash-nonfree se volvió extremadamente inestable en mi equipo provocando cierres y cuelgues del navegador web.

    La solución fue desisntalarlo, ahí volvió la calma perdiendo el flash, pero pensé que con una reinstalación se solucionaría el problema, pero cuando me puse a ello había desaparecido el rastro del flash en los repositiorios.

    Me imaginé que fue debido a la inestabilidad y que en unos días estaría de nuevo, pero tras varios meses en esta situación, el tema sigue sin arreglarse.

    ¿sabes algo acerca del tema? tirar con gnash no merece la pena bajo mi punto, lo veo como un parche mas que como una solución.

    Un saludo cordial.

  • @iqpi Si, la verdad es que muy estable no se está comportando en tanto que a menudo los flash dejan de salir y ya no lo hacen hasta que se reinicia, pero lo de los cuelgues no lo he notado.

    Sobre que ya no está, yo lo sigo viendo en la salida del apt-cache show nspluginwrapper y en la página del paquete

  • mord dice:

    Antes que cualquier cosa reciban un saludo desde México
    felicidades a las personas que se dan el tiempo para compartir informacion con la comunidad linuxera

    abusando de la confianza super coco
    a mi no me va el flash

    lord:/home/mord# apt-get install flashplugin-nonfree iceweasel libasound2-plugins mozplugger
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    El paquete flashplugin-nonfree no está disponible, pero algún otro paquete hace referencia
    a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
    encuentra disponible desde alguna otra fuente

    que puedo hacer

    acabo de instalar me debian testing

    por cualquier comentario gracias

  • mord dice:

    despues de googlear lo he solucionado tomando cosas de varios foros como este
    cuando llegue a tener mas experiencia en linux difinitivamente hare aportaciones

  • @mord Si lo que no encuentra es el paquete flashpluing-nonfree, seguramente es porque no tienes el repositorio non-free configurado. Asegúrate de ponerlo en el /etc/apt/sources.list así:

    deb http://ftp.debian.org/debian/ testing main contrib non-free

    Y después haz un apt-get update.

  • yaxel84 dice:

    Hola a todos. gracias de antemano por las respuestas. Soy un usuario de window$ desde hace varios años y estando cansado de utilizarlo por sus continuos problemas, parches y demas, aunque la verdad solo lo uso como wintendows… jejeje….. he empezado a investigar acerca de linux (distros) -voy aprendiendo algo- y he instalado el debian etch 4rc3 stable amd64 en una maquina virtual -usando vmware- para hacer la transición muy pronto y borrar de mi disco win$, aunque mi hermano si lo usa para sus trabajos en la universidad (macromedia, corel -diseño gráfico-) y tendre que instalaro dual-boot, en fin, mi problema, al igual que el de mord, cuando quiero instalar el plugin para flash en el Iceweasel me manda el mismo error, hice luego lo que dices Super Coco, agregar el repositorio non-free, pero lamentablemente me arroja el siguiente error luego de hacer el apdate (al final):

    # apt-get update
    ….
    ….
    Leyendo lista de paquetes… ¡Error!
    E: Dynamic MMap ran out of room
    E: Ocurrió un error mientras se procesaba smokeping (NewVersion1)
    E: Problem with MergeList /var/lib/apt/lists/ftp.debian.org_debian_dists_testing_main_binary-amd64_Packages
    E: No se pudieron analizar o abrir las listas de paquetes o el archivo de estado.

    (este error me sale al final del update) cuando hice el upgrade a ver si “atracaba” -mi mania de wind$- me sale el mismo error (arriba).

    asi q cuando quise instalar el plugin, me sale esto:
    # apt-get install flashplugin-nonfree iceweasel libasound2-plugins mozplugger
    Leyendo lista de paquetes… ¡Error!
    E: Dynamic MMap ran out of room
    E: Ocurrió un error mientras se procesaba smokeping (NewVersion1)
    E: Problem with MergeList /var/lib/apt/lists/ftp.debian.org_debian_dists_testing_main_binary-amd64_Packages
    E: No se pudieron analizar o abrir las listas de paquetes o el archivo de estado.

    perdón por escribir tanto, es que como ya te dije estoy empezando con linux, y por favor, no me digan que empiece por ubuntu o mandriva o tal y cual, para ese caso me quedaria con win$, quiero aprender linux y he oido que debian es el menos fácil, asi q me encantan los retos, pues al terminar de instalar, me quedo el sistema en modo consola y excelente, pues investigue muxo más de lo que yo pense, y la verdad me gusta muxo el modo consola. Bueno, he investigado en cuanto foro he encontrado, ayudas, san google todopoderoso… pero nada (flashplayerplugin), lo que aun no me queda claro es lo de testing, unstable, stable; creo yo, que siendo estable (mi Debian 4 r3 Etch, debería de tener todo ok?, bueno, perdon por la ignorancia, y gracias por la atención a este post y de antemano muchas gracias por la respuesta… y nuevamene, perdon por escribir tanto… gracias

  • yaxel84 Creo que todos los problemas te vienen por el error:

    E: Dynamic MMap ran out of room

    Si lo buscas en Google, encuentras páginas que te dicen que deberías incrementar el valor de la caché de APT en /etc/apt/apt.conf:

    APT::Cache-Limit 12582912;

    De todas formas, tu distribución es la estable. Como el nspluginwrapper está en la testing, tú no podrás instalarlo desde el repositorio. Tendrás que pasar a usar la testing o esperar a que la testing se convierta en la nueva estable (5.0) y entonces migrar.

    Por cierto, de las distribuciones que yo he probado, la que más conocimientos me ha parecido que requiere (no digo que sea “más difícil”) es la Gentoo.

  • yaxel84 dice:

    Hola Super Coco, gracias por la respuesta…. logre encontrar el nspluginwrapper.rpm, lo converti usando el alien y logre instalarlo, hice todos los pasos que indican en la misma pagina de Adobe/Flash para sistemas amd64, pero no sucede nada, es mas, buscando aqui y alla en san google, pero -snif snif- no logro levantar el flashplayer, por lo menos verlo en youtube, y me dije -no sera por el javaScript???– asi que ando en eso…. y de paso aprendiendo poco a poco algo, lo q me tiene intrigado es lo del escritorio gnome, me salio un error del navegador epiphany y me decia que probablemente era por mi gnome q era una version antigua (2.14) e investigando me doy con la sorpresa de q está la version 2.20 de gnome, perdona la siguiente pregunta…. al ser mi distro stable y haber sido publicada hace un mes la r3 (20080217), xq no trae la ultima version de gnome, al menos he encontrado que para debian esta la 2.16, pero q dice que podria compilarla -santa madonna, y como se hace eso— como lei en otro foro: “..uno escucha la palabra compilar y los usuarios salen despavoridos…” :)… voy a leer algo de Gentoo, como dicen a lo mejor encajo perfectamente con uno o con otro… jejej…. decisiones…decisiones (mismo marcianito de looney toons)… gracias por todo y seguire investigando… un saludo Super Coco

  • @yaxel84 La versión estable de Debian es famosa por ser “muy” estable. Y es tan estable a causa de que suele llevar versiones relativamente viejas que son conocidas por ir muy bien y no dar ningún problema.

    Si quieres estar en lo alto de la ola en lo que se refiere a versiones, definitivamente Debian estable no es la distribución que necesitas, porque siempre tendrás la frustración de no tener versiones y productos que otras distribuciones ya tienen.

  • yaxel84 dice:

    Hola Super Coco.

    Lei en un foro el mismo problema, y le decian al postero que mejor se cambie a Lenny, q tambien era muy estable….mmmmm….. es lo que no me queda claro, la primera vez que fui a un curso de linux, lo q me dejo marcado fue la de “tengan cuidado cuando usen una version en prueba, pues como esta en esa fase podría dañar el equipo…” y bueno, me quede “traumado” con esa expresion….. También lei en Distrowatch que debian salia estable a un promedio de 1-3 años???? xq tanto??? -sera por eso que en los foros las fechas que veo de debian etch son de fines de 2006 y 2007, rara vez encuentro con 2008, y las demás cada seis meses.

    Luego lei por alli también que Ubuntu era la rama “de prueba” de Debian… hay tanto que aprender, pero en eso ando, y aun no puedo con el Flashplayer… pa romperse la cabeza…. “a palazaos aprendi….”,

    También lei como me comentaste de Gentoo, y lei que era mas para desarrolladores y administradores (servidores)…. mmmm, no doy para tanto todavia, pero eso si, me gusta programar…..

    Ahora ando buscando como conectarme a mi red de wintendow$, en debian puedo ver los equipos de la red, pero no tengo acceso a ellos……

    Lo que si tengo que aprender pero YA!!! es como compilar, acabo de descargar la version 2.3 del openOffice y Javaruntime que se necesita para poder usar el openOffice y no se como instalarlos, xq el openOffice que viene con Debian es la 2.0.4… wow, si que anda atrasada….. y los famosos repositorios, q te lo hacen todo, mmmmmm, solo le dices que instalar y listo…

    En fin, seguire “buceando en las profundidades de internet….” jejeje

    un saludo y perdón por escribir tanto

  • @yaxel84 Pues espero que te vaya muy bien con Linux, elijas la distribución que elijas :-)

  • yaxel84 dice:

    Hola, luego de dos meses vuelvo a escribir, y comentarte que la distro que estoy usando siempre es la de Debian amd64, y me ha ayudado bastante, pues poco a poco estoy dependiendo mas de la consola, pero en lo des busquedas, tengo que recurrir a la interfaz grafica que lo hace…jejeje, ya investigare en modo consola…. resolvi usar la version lenny, ya q esta super actualizada en relación a la Etch. Pero para amd64 si que no la ponen “tan fácil” como en la de 32 bits….weno…. ahora estoy rompiéndome la cabeza tratando de correr el virtualbox, logro ejecutarlo, pero cuando quiero iniciar la instalacion de una VM, me sale el error del vboxdrv (kernel not installed):


    VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Please install the virtualbox-ose-modules package for your kernel and execute ‘modprobe vboxdrv’ as root.
    VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

    Código Resultado:
    0×80004005
    Componente:
    Console
    Interface:
    IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

    Y lo vuelvo a compilar y funciona y puedo instalar la VM, pero cuando quiero volver a usarla digamos dos días despues de haberla instalado (o al dia siguiente) me vuelve a salir el mismo error, del vboxdrv, que no existe y vuelvo a compilar para poder usar la VM y santo remedio, el problema radica en estar compilando cada dia que quiero usar el virtualbox ¿sabes de alguna manera para no tener que compilar cada vez que quiero usarlo? En Etch no tenia ese problema y era tambien 64 bits, solo en lenny me pasa eso,.

    Como antecedente te digo que use la misma vercion del etch en lenny, pensando que no saldria ese error, pero na, sigue igual, ahora en lenny tambien instale el virtualbox-ose y me pedia compilar los módulos, también lo hice, pero siempre salia el error del kernel (vboxdrv)…… he googleado, foros, blogs, pero nadie dice como lo resolvio, (supongo que se refieren a compilar el kernel)

    /etc/init.d/vboxdrv setup

    Todos los pasos los hago como # y no como -$…..

    Ojala y pudieras decirme como evitar el re-compilar el kernel cada vez que quiero usar el virtualbox….

    Gracias por la paciencia….

    PD también he descargado la ultima version de la site oficial del virtualbox, ahora de Sun

  • @yaxel94 Lo que cuentas me suena a que cuando recompilas el kernel consigues que se arranque de ese kernel pero que cada vez que la actualización de Debian Lenny te actualiza el kernel, cosa que sucede a menudo, te reemplaza tu kernel compilado.

    Te sugeriría que le pusieras a tu kernel personalizado un nombre diferente tal y como cuento en:

    Compilar el kernel de Linux

    Además, revisa si el GRUB mantiene las líneas referentes a tu kernel personalizado (también se habla de eso en la entrada anterior).

  • yaxel84 dice:

    Hola y gracias…. mi problema era con el vboxdrv que me decia que no estaba y que habia que compilarlo, bueno para no hacer eso simplemente hice lo que lei en un post, hacer un .sh y en él hacer esto: gksu /etc/init.d/vboxdrv restart, luego que inicie el virtualbox y listo, ya corre mi equipo virtual….

    gracias por la info, por lo pronto eso de compilar mi kernel, como que todavia lo veo verde el poder hacerlo…. tal vez en un equipo virtual? hay que tener su buen recorrido para compilar mi propio kernel…..

    Gracias por tu ayuda. Saludos

  • @yaxel84 Pues sí, es una buena idea ir probando en un sistema virtual :-)

  • oZzO dice:

    Hola que tal, tu tutorial me sirvio de mucho la vez que instale debian en mi lap turion 64, esta vez, por cuestiones de espacio fue formateada, pero el dia de hoy estoy de vuelta con lenny x64.
    El motivo del comentario es sobre que el flashplugin-nonfree no ha podido ser encontrado en los repositorios que he probado, debian.org, repositorios de mexico y de rediris, efectivamente los he probado con non-free y no encuentra el paquete.
    De antemano, gracias! y si encuentro una solucion la publicare aqui mismo.
    Saludos

  • @oZzo Ten en cuenta que el nspluginwrapper está en contrib. ¿Tienes ese repositorio agregado? En cualquier caso, siempre te lo puedes bajar de la página del paquete, cuyo enlace ya aparecía más arriba.

  • oZzO dice:

    Que tal!, ya resolvi mi problema, el paquete flashplugin-nonfree ya no se encuentra en “testing”, asi que agregue repositorios de “unstable”, baje el paquete, volvi a mis repositorios de testing e instale los paquetes que aqui indicas y todo va de maravilla.
    Gracias y espero que esto ayude.

  • @oZzo Me alegro de que hayas podido solucionar el problema :-)

Trackbacks y pingbacks:

Tema LHYLE09, creado por Vicente Navarro